Two questions: mobile menu and blog items

Home Forums Himalayas Free Two questions: mobile menu and blog items

This topic contains 6 replies, has 3 voices, and was last updated by  Ashish 3 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1362199

    dskirk
    Participant

    Hello,
    My URL is http://davidk.byethost7.com/ and I am very very pleased with the Himalaya theme, and have two issues:

    1. The mobile menu does not work. The hamburger icon is there, but nothing happens. Please advise how to fix this.

    2. My blog items (shown on my menu as ‘Projects’ are all using the template for centered content, but when I click the ‘View All’ button, it shows them all left-justified. Please advise how I might cause them to be centered?

    Thank you very much,
    david

    #1362234

    dskirk
    Participant

    I have an update. On my smartphone, I scrolled down to a portfolio entry and clicked it and then the menu started working. I can’t say I know what happened, but the mobile menu is now working. And I noticed a white space appears under header in portrait view. Can you advise a fix to prevent that? I will be very appreciative of that. Thanks again for this super theme.
    david

    #1362308

    Nilan
    Moderator

    Hi dskirk,

    Please add the following CSS code to the additional CSS.

    @media (max-width: 768px) {
    
        .main-title:before, .main-title:after {
            width: 30px;
        }
    
        .main-title:before {
            left: -50px;
        }
    
        .main-title:after {
            right: -50px;
        }
    
    }
    
    @media (max-width: 480px) {
    
        .main-title:before, .main-title:after {
            display: none;
        }
    
    }

    Regards,
    ThemeGrill Support

    • This reply was modified 3 months, 1 week ago by  Nilan.
    #1362353

    dskirk
    Participant

    Thank you. That did not fix the white space on smartphone; it created a border on right side instead. However, before adding that code, I was unable to get hamburger menu to work in Android tablet, but now it works. That seemed to fix a bigger problem. That white space under header on smartphone would be nice to fix, but not urgent. For now, I removed
    @media (max-width: 480px) {

    .main-title:before, .main-title:after {
    display: none;
    }
    }

    I am still having some big difficulties with tablet.
    Sometimes in portrait mode, the hamburger menu doesn’t work until I scroll down and click a portfolio entry first and then it works fine. And if I switch to landscape mode and back again to portrait mode, I have to repeat the process to see the menu again. I would really appreciate help in this.

    ALso, sometimes in landscape mode, the two right-most menu items (‘Our team’ and ‘Contact us’) don’t work or cause the entire webpage to disappear when I use Chrome browser, and those menu items sometimes cause the webpage tied to ‘About us’ to load when using the Opera browser. Puzzling. These problems don’t happen all the time.

    I also noticed that sometimes when one menu item is highlighted and I select a new menu item, both become highlighted and nothing happens. I wait a few seconds and click a third menu item and it works again.

    These issues are just in tablet mode and any insight will be appreciated. The site works great on desktop and smartphone. I will welcome any suggestions.

    On a secondary issue, not as important,
    When I click ‘view all’ to blog items (I call them projects), they show left-justified, although I use the template for centered. Individually, they show properly. It’s just in ‘view all’ that they appear left-justified. I would like to fix this too, with your help, although not as important as the tablet issue.

    Thanks very much for any insight and suggestions.
    regards,
    david

    #1362744

    Ashish
    Moderator

    @dskirk
    While checking your site on a tablet device, we could not replicate those issue as you mentioned, which device exactly are you using?

    Also for blog page layout please select No Sidebar Content Centered from Blog page edit screen.

    Thanks.

    #1362808

    dskirk
    Participant

    First, I appreciate your help. Much appreciated. Maybe I was having a connection problem. The pages seem fine today. I regret any confusion.

    On the Post page layout, I do have the posts set to the template for no sidebar content centered and they look good when clicked. However, when I click VIEW ALL, the theme uses a different template, possibly the full width template, that has the photos left justified. I would like to use the no sidebar content centered template for the ‘View All’ button as well, if possible. Please advise. The theme has given me an attractive site and I’m trying to tweak this one issue.
    Thank you,
    david

    #1362898

    Ashish
    Moderator

    @dskirk
    Correct me if I’m wrong. You want this blog page: http://davidk.byethost7.com/blog/ to be No Sidebar Content Centered. Isn’t it? If so, simply go to dashboard edit screen of that particular blog page and select the same layout as shown image below.
    It seems you still No Sidebar Full Width layout for blog page so, it’s displaying that way.

    View post on imgur.com

    Hope you understand. If not, let me know again 🙂 Thanks.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.