TG About Widget button problem

Home Forums eStore Pro TG About Widget button problem

This topic contains 12 replies, has 4 voices, and was last updated by  Bishal Napit 1 year, 11 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1306931

    Amella
    Participant

    Hi,

    I have a problem with the TG About Widget.

    When i put a link in the “button redirect link” no link work … i have only a href=”#” ..

    What is the problem ?

    My site is : https://contract.kf-moebel.de

    Thanks a lot !

    Frédéric

    #1306970

    Hello Amella,

    Please add the desired link instead of ‘#’
    It is working perfectly fine in our local environment, you can deactivate the plugins used to see if any plugin si creating the issue.

    Regards,
    ThemeGrill Support Team

    #1309608

    Amella
    Participant

    Hello,

    I have found the plugin which made the button link deactivated : it is WPML String Translation.

    When i deactivate it, i have a link, when i activate it, there is no link.

    EStore Pro is compatible with WPML … what is the problem ?

    Regards,

    Frédéric

    #1309710

    Bishal Napit
    Moderator

    Hi, Amella.

    We will be fixing this issue in the version update of the theme. Thank you for notifying it to us. We really appreciate it. Thanks.

    #1309711

    Bishal Napit
    Moderator

    Hi, Amella.

    Also, can you make sure that you are adding the required ‘Button Text:’ too in that widget? While we checked properly, there was translation string issue but, however we could see the button with that issue too. So, can you check the same and confirm once? Thanks.

    #1309731

    Amella
    Participant

    Hi,

    As you can see, I have adding the required text.

    https://www.dropbox.com/s/218oxwjv13q4pqd/Capture%20d%E2%80%99%C3%A9cran%202017-05-30%20%C3%A0%2011.10.49.jpg?dl=0

    I have disabled the WPML String Translation because I need to have access to the link. So i am waiting on your update to activate the multilingual feature of my site.

    Thanks for your answers.

    Regards,

    Frédéric Amella

    #1309733

    sajantg
    Moderator

    Hello @Amella,

    We will update fix about this in our next version. Can you please provide us the theme version number you are currently using?

    Thanks.

    Themegrill.

    #1309734

    Amella
    Participant

    Hi,

    I use the 2.1.4 version !

    Regards.

    Frédéric

    #1309888

    Bishal Napit
    Moderator

    Hi, Amella.

    Can you provide us the plugin list used on your site or the temporary login access to your site so that we could have a better look on this issue? While we checked in our local development environment, then, we could not replicate the same and seems to be working fine even on that plugin is installed and activated. Anyway, once can you edit the theme code of file ‘inc/widgets.php’ which code to be changed is: $button_url = icl_t( 'eStore Pro', 'TG: About button link'. $this->id, $button_url ); to $button_url = icl_t( 'eStore Pro', 'TG: About Button Link'. $this->id, $button_url ); and check once if you want to try it yourself, which is coming up in the upcoming version update of the theme, so, you do not need to worry on this at all? Thanks.

    #1309918

    Amella
    Participant

    Hi Bishal,

    Thank you for this help. When adding this modification to the inc/widgets.php all is ok !

    Do you want a temporary admin access anyway ?

    Regards.

    Frédéric AMELLA

    #1309919

    Bishal Napit
    Moderator

    Hi, Amella.

    If all is ok, then, absolutely fine. We now might not require the temporary login access at all to check for the tissue, as you stated it is dealt with. Thanks.

    #1309920

    Amella
    Participant

    Ok ! Thanks a lot !

    Regards

    #1309924

    Bishal Napit
    Moderator

    Hi, Amella.

    Do let us know if there are any further query regarding to our theme. Thanks.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.