Parallax header

Home Forums Himalayas Free Parallax header

This topic contains 10 replies, has 3 voices, and was last updated by  panjonatan 2 weeks, 4 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1624576

    panjonatan
    Participant

    Hello,

    I was wondering, if there is any way to set up the parallax effect for the header image. Just a basic scrolling over the header image. Could you help me with this one, please?

    Thanks.

    Peter

    #1625738

    Nitu Shrestha
    Moderator

    @panjonatan

    It will require lots of code customization work which cannot get covered up via any support platform. Hope you can understand.

    Thanks.

    #1630325

    panjonatan
    Participant

    Well, that is what I thought. I have found a way around, but have lost the transparency of the header in the process.

    I left the header menu empty and placed the background picture in the editor. Then, following the advice on this forum, I have hidden the page title and the white space using this additional css:

    .home .entry-content {
        margin-top: 0;
    }
    
    .home #main {
        margin-top: -10px;
    }

    Afterwards I just created a basic parallax effect using html and css.

    Could you please help me to fix the header? The site can be found at relis.sk.cluster3s47.dnsserver.eu

    Many Thanks.

    Peter

    #1634311

    Nitu Shrestha
    Moderator

    @panjonatan

    Can you visit Appearance-> customize -> Himalayas Header Option -> header transparency section and uncheck to make header transparent and check?

    Thanks.

    #1640476

    panjonatan
    Participant

    Sure. Done that before, but nothing changes. I tried to watch in the inspect element view, what actually changes when I check/uncheck that box, but I could not spot the change. This is what it looks like:
    https://1drv.ms/u/s!AqPt8-OnGnI8gZ8Z8Mqc7TwPjHMO2A

    Notice the “non-transparent” in the body class, even though the box is unchecked. When I manualy rewrite that to “transparent”, it works, but just until I reload the page.

    I do not really need the option to change it to non-transparent, so if there would be some way to change it for good…

    Thank you

    #1645186

    Nitu Shrestha
    Moderator

    @panjonatan

    Your site seems to be in maintenance mode. So, can you disable it and let us know to check?

    Thanks.

    #1647401

    panjonatan
    Participant

    You should be able to get in now.

    #1697905

    Nilan
    Moderator

    Hi,

    Please try the custom CSS below by adding it to the additional CSS box.

    .non-transparent .header-wrapper {
        background: rgba(51, 51, 51, 0.2);
    }
    
    .non-stick.non-transparent #content, .home.stick.non-transparent #content {
        margin-top: 0;
    }

    Regards,
    ThemeGrill Support Team

    #1698398

    panjonatan
    Participant

    It worked, thanks a lot for your help.

    Kind regards,

    Peter.

    #1717810

    Nitu Shrestha
    Moderator

    @panjonatan

    Do let us know if you have got any further query regarding to our theme.
    We will really appreciate if you could help us too by rating our theme in WordPress repo here:-
    https://wordpress.org/support/view/theme-reviews/himalayas

    Thanks.

    #1831652

    panjonatan
    Participant
    This reply has been marked as private.
Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.