Old hidden http link causes mixed content in Firefox

Home Forums ColorMag Free Old hidden http link causes mixed content in Firefox

This topic contains 11 replies, has 3 voices, and was last updated by  Bishal Napit 3 years, 2 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1237295

    tom.oehlert
    Participant

    Hello,

    I really like the colormag theme. Now I changed to https and I got a problem with mixed content at my page: https://gluecksburg.ch
    When you open it with firefox you will see it. The reason is an old link to https://gluecksburg.ch/gluecksburg/wp/wp-content/uploads/2015/10/favicon.png
    When you open the firefox console its listed as a security problem. But that content does not exist! I can not find a way to delete that link. I tried to find it with notepad++ and searched in all files. I tried it with the theme editor in wordpress. I can not find the link and I made the theme update. When I changed the theme I havent any problems with mixed content anymore. But I would really like to stay with colormag.

    It would be very grateful if you would help me with that problem.

    Best regards,

    Tom

    #1237308

    Bishal Napit
    Moderator

    @tom.oehlert

    Can you try it once again by updating the favicon for your site and check? Thanks.

    #1237315

    tom.oehlert
    Participant

    Yes, I tried that before. There was no effect.

    #1237682

    Banstola Rajeeb
    Moderator

    Hello Tom,

    Please remove the favicon from theme’s option and add that same icon via Appearance -> Customize -> Site Options and check if that helps.

    Thanks!
    ThemeGrill Support Team

    #1237807

    tom.oehlert
    Participant

    Hello Banstola,

    there wasnt any active favicon in appearance -> customize -> site identity. But I saved a new one there, removed it and saved it again. But the problem persists.

    Do you have any other ideas?

    Thanks!

    Tom

    #1237961

    Banstola Rajeeb
    Moderator

    Hello Tom,

    Sadly I’ve run out of ideas. Please try creating a child theme and hard-coding favicon link in header.php

    Thanks!
    ThemeGrill Support Team

    #1238246

    tom.oehlert
    Participant

    Ok, what could I do there? Could you give me advise please?

    Thanks!

    #1238384

    Bishal Napit
    Moderator

    @tom.oehlert

    Here is the link on creating the child theme: https://themegrill.com/blog/tutorial-on-creating-wordpress-child-theme/. Here, in the child theme, duplicate ‘header.php’ file and add the favivon code as required in this file just below this code: <link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>" />. Thanks.

    #1238769

    tom.oehlert
    Participant

    Dear Bishal,

    thank you for your ideas. Look, I don´t want to add something. I want to delete the old link in the theme https://gluecksburg.ch/gluecksburg/wp/wp-content/uploads/2015/10/favicon.png

    I can not locate this command.

    How can I find and delete it?

    #1238775

    Bishal Napit
    Moderator

    @tom.oehlert

    You can visit Appearance->Customize->Additional Options->Activate favicon section and uncheck the checkbox having the option of ‘Check to activate favicon. Upload favicon from below option’ and see if it helps. Thanks.

    #1238781

    tom.oehlert
    Participant

    Dear Bishal,

    I unchecked that and.. it worked. Now I haven´t any SSL errors!!

    Thank you so much.

    #1238783

    Bishal Napit
    Moderator

    @tom.oehlert

    Nice to know that the issue has been solved. If there are any further query regarding our theme, then, please feel free to post them.
    We will really appreciate if you could help us too by rating our theme in WordPress repo here:-
    https://wordpress.org/support/view/theme-reviews/colormag
    Thanks.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.