Home Page Mistakenly displays Blog

Home Forums Flash Free Home Page Mistakenly displays Blog

This topic contains 4 replies, has 2 voices, and was last updated by  Ashish 9 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1384091

    sabonfigli
    Participant

    In Settings->Reading, I’ve checked off “Static Page” and set homepage to “Home” and posts page to “Blog”. It’s been this way since I created my Web site. It still looks like this today.
    However my Blog Posts Page is now appearing as my Home Page (https://BeachDelight.com). I don’t believe I changed anything other than installing and activating Gutenberg Editor a couple of weeks ago. I signed on to WordPress and saw that the Gutenberg editor was no longer installed. (I don’t know if this is expected behavior. Is it supposed to go away and require re-install every time you sign back into to edit your WordPress site?)

    I did notice that the Home Page when using the regular WordPress Editor now contained the home page contents and layout that I was only able to see previously when editing using Appearance->Customize. I think that in the Pages list for my home page, it had some default “Welcome” text. Net: I always and only edited the static home page by going through Appearance -> Customize. Now it looks like I can edit the Home Page contents using the page listed in WordPress Pages.

    Even though my settings are configured for a static home page and the page is defined as “Home”, it’s my blog posts page that is showing up instead.

    I need direction on how to ensure my static page is displayed as my front page. Thanks.

    #1384160

    Ashish
    Moderator

    Hi @sabonfigli
    It seems you’re not using our theme. So, we are not able to provide support to your query. You can switch to our theme and ask again. Hope you understand. 🙂 Also, if you’re using our theme please make sure the site link you’ve provided is correct.

    Regards,
    ThemeGrill Support Team.

    #1384202

    sabonfigli
    Participant

    I’m using
    Current Theme
    Flash Version: 1.2.2
    By ThemeGrill

    #1384207

    sabonfigli
    Participant

    Update: This is so very strange. Within minutes of submitting my forum posting, I noticed that my home page did display correctly on my PC. However, on cell phone, refrigerator screen and tablet, my blog still showed up as the home page.

    Trying to see if I can avoid the problem until it’s resolved, I reinstalled the Guttenberg editor and I took the Text from my home page (again, having my Home page text show up outside the customizer is new for my Flash theme) and created a new page. Although the Guttenberg Editor was available to me, I didn’t use it. I created a duplicate page that matched my home page. I added this page to my Menu. I since removed it from my menu. The new duplicate page is defined on my site, but no longer listed on my menu.

    I refreshed my cache. Nothing changed.

    This morning, I checked all the various devices and all show the correct Home Page. I, effectively, changed nothing. Yet something obviously caused my Posts page to show up in my Home Page link for a period of time…and the period of time appears to be different between PC and mobile devices.

    The problem is gone now — it’s a mystery.

    #1384328

    Ashish
    Moderator

    Hi @sabonfigli
    Sorry for misunderstanding! While checking yesterday I realized it’s not Flash theme. 🙂 Anyways, Great to know that your issue is gone now. If you’re still using Gutenberg plugin, you should uninstall and remove it from your live site as it is still in testing phase.

    Let us know if you get any issue later.
    Thanks.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.