Blog posts not showing on homepage

Home Forums Radiate Free Blog posts not showing on homepage

Tagged: ,

This topic contains 4 replies, has 3 voices, and was last updated by  mat.jo1991 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1290039

    clare
    Participant

    I have 3 blog posts published, but only one is showing on the home page. I have the # set to 10 in the “reading’ settings of WordPress. The one that IS showing on the home page is NOT showing up under myurl/blog page, however.

    I’m very confused, can you help?

    www.yourbluecanoe.ca

    #1290215

    Nima
    Moderator

    Hello @clare,

    Please, go to the options Appearance->Customize->Static Front Page and set posts page as your “Blog” page. Now, only this page will response as blog page and all of the created posts will be displayed here.

    Thanks!
    ThemeGrill Support Team

    #1290245

    clare
    Participant

    I have changed it to static front page and selected ‘blog’, however now NO posts are showing on the home page:

    www.yourbluecanoe.ca

    #1290324

    Nima
    Moderator

    Hello @clare,

    WordPress allows only one page to choose as blog page.
    It is not possible to display posts on both home and blog page so, we suggest you to remove the blog page and make “Home” page as both front page and posts page. As only one page can be selected as posts page to display the post.

    Thanks!
    ThemeGrill Support Team

    #1831112

    mat.jo1991
    Participant
    This reply has been marked as private.
Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.