Background Image Tiling problem

Home Forums ColorMag Free Background Image Tiling problem

This topic contains 6 replies, has 3 voices, and was last updated by  imaran738821 1 week, 2 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1225824

    mabulborneo
    Participant

    Hi guys,

    Just started using your theme, looks great so far.

    However, I ran into a problem while trying to change my background image. I need the background image to tile but instead, it is stretching.

    This is the background image I’m using -> https://subtlepatterns.com/sprinkles/

    FYI, the background image dimension is 5px x 10px or 10px x 20px…so it’s very small but this shouldn’t cause any tiling problems because it worked with other themes. I tried both dimensions with Colormag but still the image will not tile.

    My settings under ‘Customize’ are as follows:

    Background Repeat: Tile
    Background Position: Left
    Background Attachment: Scroll

    Please test it out and let me know, thank you very much.

    #1225975

    Bishal Napit
    Moderator

    @mabulborneo

    We have tried the image which you have pointed out and could not find the issue on it. Thanks.

    #1226034

    mabulborneo
    Participant

    Hi Bishal,

    Thanks for your reply but I think I’ve found the solution.

    This is how my css looked like before implementing the solution:

    body.custom-background {
        background-attachment: scroll;
        background-image: url("https://cdn.mywebsitename.com/sprinkles.png");
        background-position: left top;
        background-repeat: repeat;
    }
    body {
        background-size: cover;
        padding-bottom: 10px;
        padding-top: 10px;
    }

    The problem is with “background-size: cover“. When I used Firebug to change it to “background-size: 5px 10px” (the exact size of my background image) the tiling worked.

    May I know why this is happening? By the way, I’m using a child theme and uploaded the background using the ‘Customize -> Background Image’ section of Colormag theme.

    I set up the child theme correctly but could it be a problem because the child theme is missing other css files?

    #1226144

    Bishal Napit
    Moderator

    @mabulborneo

    For the background image CSS code, we have done nothing on it since it will be provided by WordPress on default, if it is used in the site. Thanks.

    #1226189

    mabulborneo
    Participant

    Hi Bishal, thanks for your reply. It’s weird because there was no problem with tiling background for other themes with the same plugins I’m using now. But I guess the solution will work for now. Thanks once again

    #1226302

    Bishal Napit
    Moderator

    @mabulborneo

    If there are any further query, then, please feel free to post them. Thanks.

    #1829081

    imaran738821
    Participant

    Thanks for the solution is it working

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.